Questions tagged xcode12

Explore the latest questions and answers asked by our top developers.

Build on Xcode 12 showing ‘Any iOS Device(armv7, arm64)’

I migrated my existing project to Xcode12. I had to remove VALID_ARCHS from Build Settings. And added arm64 for Excluded Architecture (Any iOS simulator SDK). Then I am able to run app on iOS14 simulator. But now while creating archive it is showing. Any iOS Device(armv7, arm64) Please refer this screenshot. In previous Xcode it […]

By Akshay
Published
Categorised as ios, objective-c, swift, xcode, xcode12 Tagged , , , ,

XCode 12: ‘SessionDelegate’ has different definitions in different modules

Edit: This problem occurs after XCode 12 Beta5. Xcode doesn’t allow different modules to define same names (Probably for public classes & protocols). Alamofire and Kingfisher appears to define SessionDelegate at the same time. I’m still trying to find a solution.. I’m implementing iOS 14 Widgets in our application. I have started working with XCode […]

By Feridun Erba
Published
Categorised as alamofire, kingfisher, swift, xcode, xcode12 Tagged , , , ,

iOS 14 / UI Testing DatePicker

I’m struggling fixing my UI tests for iOS 14 that set date on DatePicker views. They were previously running without any problems on iOS 13 when they were shown as wheel pickers. My code used to set the different wheels but since there aren’t any wheels anymore on iOS 14, this is not working anymore. […]

By G Marc
Published
Categorised as ios14, swift, swiftui, xcode12, xcuitest Tagged , , , ,

ionic serve on iOS 14 device. Error "Invalid Service"

After upgrading an iPhone6s to iOS 14 and Xcode to the latest version, I am unable to serve the app. The error stack is as following Error: InvalidService at LockdownProtocolReader.parseBody (/usr/local/lib/node_modules/native-run/node_modules/node-ioslib/dist/protocol/lockdown.js:35:19) at LockdownProtocolReader.onData (/usr/local/lib/node_modules/native-run/node_modules/node-ioslib/dist/protocol/protocol.js:52:40) at TLSSocket.emit (events.js:315:20) at addChunk (_stream_readable.js:295:12) at readableAddChunk (_stream_readable.js:271:9) at TLSSocket.Readable.push (_stream_readable.js:212:10) at TLSWrap.onStreamRead (internal/stream_base_commons.js:186:23) running with –verbose shows the origin […]

By capc0
Published
Categorised as cordova, ionic-framework, ios, xcode, xcode12 Tagged , , , ,

Swift ABI stability: Module compiled with Swift X.Y cannot be imported by the Swift X.Z compiler

Let’s start by existing questions, Module compiled with Swift 5.1 cannot be imported by the Swift 5.1.2 compiler Module compiled with Swift 5.1 cannot be imported by the Swift 5.0 compiler Module compiled with Swift 5.1.2 cannot be imported by the Swift 5.2.4 compiler And, now with XCode 12(12A7209) Module compiled with Swift 5.2.4 cannot […]

By Shekhar Gupta
Published
Categorised as frameworks, ios, swift, xcode, xcode12 Tagged , , , ,

Swift Module stability: Module compiled with Swift X.Y cannot be imported by the Swift X.Z compiler

Let’s start by existing questions, Module compiled with Swift 5.1 cannot be imported by the Swift 5.1.2 compiler Module compiled with Swift 5.1 cannot be imported by the Swift 5.0 compiler Module compiled with Swift 5.1.2 cannot be imported by the Swift 5.2.4 compiler And, now with XCode 12(12A7209) Module compiled with Swift 5.2.4 cannot […]

By Shekhar Gupta
Published
Categorised as frameworks, ios, swift, xcode, xcode12 Tagged , , , ,

SwiftUI: compiler is unable to type-check this expression in reasonable time; try breaking up the expression into distinct sub-expressions

So I have a GeometryReader encapsulating most of my contentView, struct ContentView: View { var body: some View { GeometryReader { proxy in …. } } } but I’m running into an issue with it. I pass it into various views in my ContentView with no issues. For some reason though, if I try to […]

Cannot build project with Xcode 12.0 beta 4

I downloaded Xcode 12.0 beta 5 and I’m trying to build my project, but I received the following error: <unknown>:0: error: unable to load standard library for target ‘arm64-apple-ios9.0’ I tried searching online for solutions, but none of what I found helped me to solve this error. I found this thread on SO but none […]

By Dree
Published
Categorised as ios, ios-simulator, swift, xcode12 Tagged , , ,

Cannot build project with Xcode 12.0 beta 5

I downloaded Xcode 12.0 beta 5 and I’m trying to build my project, but I received the following error: <unknown>:0: error: unable to load standard library for target ‘arm64-apple-ios9.0’ I tried searching online for solutions, but none of what I found helped me to solve this error. I found this thread on SO but none […]

By Dree
Published
Categorised as ios, ios-simulator, swift, xcode12 Tagged , , ,
1 2

Still Have Questions?


Our dedicated development team is here for you!

We can help you find answers to your question for as low as 5$.

Contact Us
faq